My in-testing OSQA site works with myOpenID and yahoo, but fails with Google. I'm attempting to register as a new user. On the google side, I get

The OpenId authentication failed: Server denied check_authentication

and in my server log I get the corresponding Server responds that checkAuth call is not valid.

What do I do next to diagnose this?

One possible thing to be aware of is that I am going through a proxy, so the local host name is not the proper access url, but I do have APP_URL set correctly in settings_local.py.


Oh: I should add that this was working in December. I updated to the newest trunk in between there (and am now at latest). So it may in fact just be a new bug.

asked 18 Jan '11, 11:01

mattdm's gravatar image

mattdm
27461012
accept rate: 0%

edited 18 Jan '11, 15:21


-1

I solved the problem here. When I updated, I ran manage.py checkinstall. This told me to install "south", so I dutifully did yum install Django-south. If this package is installed, manage.py syncdb will fail.

(So, that's a bug.)

I should add that I am running with the stock Python 2.4 until we can migrate to CentOS 6. The "bug" may simply be a version incompatibility, a fact of life I'm very willing to accept.

link

answered 19 Jan '11, 10:21

mattdm's gravatar image

mattdm
27461012
accept rate: 0%

edited 20 Jan '11, 13:26

You are incorrect. Check your facts, south intercepts that command, and there's a few more things you need to do. Use manage.py syncdb --all (having south installed) and your syncdb won't fail. You managed to be aware of the checkinstall command, which is hardly documented, but not about the correct database creation commands, which are written everywhere?

(19 Jan '11, 10:24) Hernani Cerq... ♦♦

Actually, empirical reality shows that I am not incorrect. If reality disagrees with "facts", something is definitely wrong. When I run python manage.py syncdb with south installed, it fails on "forum", and tells me to use manage.py migrate — which also fails, more spectacularly. When I remove south, python manage.py syncdb works perfectly well. I hadn't tried adding "--all", though -- the docs at http://wiki.osqa.net/display/docs/RHEL%2C+CentOS+5+Installation+Guide do not mention that. I'll go ahead and try it.

(20 Jan '11, 13:21) mattdm

manage.py: error: no such option: --all

(20 Jan '11, 13:23) mattdm

Hernâni, are you saying that if Django-south is installed, --all is necessary and will work? In that case, a) why not just make it work without --all, or at least give an error message instead of failing obliquely, and b) maybe update your documentation.

(20 Jan '11, 23:46) mattdm

And if that is the case, my answer is not incorrect — there's still a bug. (syncdb without --all breaks if south is installed, and there's no documentation to that effect. Even in the install guides which do mention south, it's only "strongly recommended", and there's no mention of the side-effects, only that it's needed to migrate databases — something I'm not worried about.)

(20 Jan '11, 23:51) mattdm
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×49
×48
×47
×10

Asked: 18 Jan '11, 11:01

Seen: 2,017 times

Last updated: 20 Jan '11, 23:51

powered by OSQA