4
4

I just created an OSQA instance, and I'm having trouble finding the tool to migrate in a StackExchange dump. I tried going to /admin/sximporter, but I got a 404 error, just like this guy.

I believe I have South set up properly, since I can do

python2.6 -c 'import south'

with no problem.

How do I get to the import tool?

asked 20 Oct '10, 10:30

Isaac's gravatar image

Isaac
91337
accept rate: 100%

edited 21 Oct '10, 15:21


Make sure you tack an extra '/' on the end: http://mysite/admin/sximporter/. It won't work without the trailing slash.

link

answered 21 Oct '10, 23:37

gperrow's gravatar image

gperrow
291121824
accept rate: 25%

edited 21 Oct '10, 23:37

Thanks! You got it.

(22 Oct '10, 03:13) Isaac

As I am running this tool, I am encountering a few issues that I wanted to document:

Permission problems, solved by:

sudo chmod -R g+w tmp
mkdir forum_modules/sximporter/tmp
sudo chown -R osqa:www-data forum_modules/sximporter
sudo chmod -R g+w forum_modules/sximporter

Conflict with existing questions. Solved by clearing the database first:

sudo python2.6 manage.py flush

link

answered 15 Jul '11, 08:33

ripper234's gravatar image

ripper234 ♦
3.3k106147129
accept rate: 19%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×40
×39
×20
×20
×17

Asked: 20 Oct '10, 10:30

Seen: 3,740 times

Last updated: 15 Jul '11, 08:33

powered by OSQA