I have a weird bug - it's driving me a bit crazy!

If I configure the 'Email settings' page as follows, OSQA sends emails just fine.

Email Server: smtp.gmail.com
Email Port: 587
Email User: myaddress@gmail.com 
Email Password: mypassword
Use TLS: [checked]

However, if I substitute in a different address - okfn.wdmmg@gmail.com and its password - no emails are sent. There is no error message in OSQA, emails just don't arrive.

I am CERTAIN this address and password are OK, I can log into Gmail with them. I have checked and POP is enabled for the address.

Does anyone have any ideas why OSQA is objecting to this address? If not, does anyone know how I can start to debug the problem?

-- UPDATE -- I can connect to another mail client (specifically, OSX's inbuilt Mail) and send emails just fine from there with the okfn.wdmmg login credentials.

So it seems like it's just OSQA and this particular Google login that's the problem...

asked 08 Sep '10, 09:13

AP257's gravatar image

AP257
86669
accept rate: 0%

edited 08 Sep '10, 12:27


Note: I had big problems with port 465. Gmail's help says you can use 465 but for me, even though it connected, it didn't work. Using Port 587 worked for me.

link

answered 24 Oct '10, 13:09

Martin%20Cleaver's gravatar image

Martin Cleaver
31114
accept rate: 0%

hi I am also having same kind of problem.SMTP work for one domain(gmail.com) and not working for another domain(live.com).I tried all way i could.But i am unable to succeed on it.If anyone had the same problem please let me know how to configure it successfully.Waiting for response.Thanks in advance.

the ERRROR is

/bitnami/apps/osqa/forum/utils/mail.py TIME: 2014-04-08 04:13:32,344 MSG: mail.py:create_and_send_mail_messages:122 Email sending has failed: Connection unexpectedly closed: [Errno 1] _ssl.c:1363: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

link

answered 08 Apr, 04:08

velmani's gravatar image

velmani
41226
accept rate: 0%

edited 08 Apr, 04:11

This is not an OSQA issue, but rather something about what Gmail allows and doesn't allow. Gmail is very particular about SMTP sender authentication. If you want to choose an arbitrary email address for the sender, then you will need to find another SMTP host besides Gmail.

link

answered 08 Sep '10, 09:17

rickross's gravatar image

rickross ♦♦
13.5k3819480
accept rate: 47%

It's not an arbitrary address - it's a valid Gmail address with which I can log into Gmail perfectly fine, and POP is enabled on the Gmail account. What makes you think it might be a Gmail issue?

Also, would a failed attempt to send email get logged anywhere in OSQA, so I can see the exact error with which it's failing?

(08 Sep '10, 09:27) AP257

I can connect to the okfn.wdmmg address from other mail clients (specifically, OSX's inbuilt Mail client), and send mails just fine from there. I've updated the question to say this.

So I am inclined to think that it's an OSQA issue.

Any ideas?

(08 Sep '10, 12:24) AP257

Still struggling...

I've noticed that if I enter an invalid password in Email settings, OSQA doesn't throw an email when I try to send a validation email. It says 'A message... was sent to your address'.

Would it be better if this waited for a receipt, and displayed a failure message if the server rejects the SMTP information?

Also, please could you tell me where the failure messages do get logged, so I can try to work out what's going on?

link

answered 08 Sep '10, 13:22

AP257's gravatar image

AP257
86669
accept rate: 0%

Have you looked on the log? on the log folder in the root of your OSQA install.

(08 Sep '10, 13:33) Hernani Cerq... ♦♦

There's nothing in there from today, which is when I've been trying to set up SMTP - so it looks like SMTP failures don't get logged :(

(08 Sep '10, 14:19) AP257
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×115

Asked: 08 Sep '10, 09:13

Seen: 1,724 times

Last updated: 08 Apr, 04:11

powered by OSQA